Cannot submit support ticket

Hi, i would prefer to NOT create a community post about this but do not feel like i have another option.
Right now i cannot submit support tickets. the submit button does nothing.
Anyone else?

i tried to mail “” but this does not accept new tickets.
And i am having trouble getting responses from my account manager recently, not sure what else i can do…

Hi @alex.rademeyer ,
Let me try to help!

Can you please visit this link: Auth0 Support Center to see if you can submit a ticket?

Please let us know how it goes.

Hi @marcelina.barycka ,

This does not work, no: that is literally the problem i am describing.

Hmm, if you visit the main support page (, are you logged in to the tenant with a paid subscription (the right upper corner)?

@marcelina.barycka I am logged in yes :slight_smile:

Alright, I can see that there was a request around tenants deletion. I will DM you.

1 Like

I’m also having this issue, I’ve followed all the steps mentioned above but when I click “Submit Ticket” the button greys out with no error or apparent action. I’ve tried two different browsers and my colleague could replicate from their account so I’m confident it’s not a client side issue.

Please could someone contact me so I can raise my issue?


Tried again today and this is working now :man_shrugging:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.