Cannot locate email template

Hi - using the API, I am creating a new login for my auth0 SPA.

The email associated with the account receives a “Verify you email” email.

I cannot however find the template for the email in question. The “Verification Email (using link)” template is different from the one I receive. I have tried looking into the raw HTML email, and search for specific words that should be there, but they are not.

If I verify my email, and the use the Try feature for the template in question, then I do get an email corresponding to the template, but this is still not identical to the first email.

Any help would be appreciated.

Kind regards
Thomas

Hi @xtmk,

Are you using a custom email provider or the built in Auth0 provider? Also, are you on a free, trial, or paid plan?

Hi Dan - I am on a paid plan. We’re using a custom mail provider, which is office 365. We are using it with an SMTP server of smtp.office365.com

Kind regards
Thomas

It should be sending the verification email (link) template on first signup. Have you toggled the status to on and successfully saved the template after making your changes?

If you have done both of those things, can you please DM me your tenant name so I can take a look? Thanks.

I had not set the “status” toggle - what does it do?

I did save the template after I made some changes to it. I will try with the “Status” toggle set, and see what happens.

Kind regards
Thomas

1 Like

Enables or disables the template.

Ah - nice. :slight_smile:

I will try that first then.

Thanks
Thomas

1 Like

Sounds good. Let me know what happens.

Well, that seems to work. Nice :slight_smile:

Maybe the label should be called something like “Customize email” or “Enable” instead of “status”.

Another question:
When I create a customer using the API, the customer should confirm the email. Is there a way to customize the page shown for the “confirm email” ?

Kind regards
Thomas

Which email is it? Can you give a screen shot or example?

Hi Dan - I am no longer sure which page it was.

I found the pages I was searching for underneath the universal login. I guess what tricked me was the fact that some of these page templates has several pages. I also was missing a comma in some of the javascript, which caused to it show a blank page.

All is good for now. :slight_smile:

Regards
Thomas

1 Like

Great! I am going to mark this resolved.

It was the status toggle that needed to be turned on.

1 Like