Auth0 Home Blog Docs

Cannot configure transaction record

wordpress-login-with

#1

Hi - I configured the auth0 Wordpress plugin which was working well, however, suddenly now I’m now getting an error when I try to log in as a user:
There was a problem with your log in Cannot configure transaction record.
I’ve tried disabling other plugins.
Can anyone suggest what might be the issue?
Thanks


#2

Yup, I’ve just got the same thing, I have a busy site and now users cant logon!
I am running on Ubuntu and did a whole bunch of updates earlier, the other server I run this on is working fine. The strange thing is, users who have already logged in and the remember logon session is on… they can continue to use the site.


#3

I’ts not just wordpress, we are using the auth0 lock and get the same error in the hash params after successful sign in.
"#error=server_error&error_description=Cannot%20configure%20transaction%20record."


#4

BTW, we’re using username-password authentication.


#5

Hmm so a bigger problem. We’re using the O365 connection. Don’t think that makes any difference since at least 3 of us are having the same issue and different setups.


#6

Are you on the “free plan”?


#7

I’m getting this and on the “free plan” it just started this afternoon


#8

I’m not using any connections, just raw Auth0


#9

same problem with my wordpress servers. just started.


#10

I’ve tweeted to https://twitter.com/auth0status?lang=en but no response there or any admission of issue.


#11

We are seeing this same issue :frowning: I tried calling Auth0 and received no answer so I left a voicemail.


#12

This is affecting my site using lock for social as well as db logins


#13

Here is what I’m seeing from any kind of error perspective.
What’s weird is I have multiple sites using this and one of them isn’t experiencing the issue.
![alt text][1]


#14

ok after research it was only effecting one site, I went in and blew out the settings (it’s wordpress) and logged in without auth0 and recreated the settings by mirroring another site that was working.

I have no idea why though… I haven’t changed those settings in weeks.


#15

What settings did you modify?

I only have 1 site and it isn’t working so I don’t know what settings could be affecting it.


#16

I just killed all the settings under wp_auth_settings using mysql and then recreated them from the wp-admin ui… I copied the old settings entry before I erased them but due to the way WP stores settings info it’s not straight forward what is different.
I’ll see if I can figure it out real quick.


#17

The settings are different the old one has 75 settings and the new one has 64 which my guess is due to the original being on an older version of the plugin.

The only thing I can see different was auth0_implicit_workflow was set to false in the old (not working version) and I set the new one to true (which is what it should have been)

It’s possible that is more than that… I’ve attached a sanatized version of both files if anyone wants to dive in more.[link text][1]


#18

How did you kill the settings under wp_auth_settings?


#19

I used a mysql client (valentina studio) and just cleared them out.
but something like below should work in php_myadmin or something similar (not tested)

DELETE FROM wp_options WHERE option_name = ‘wp_auth0_settings’;


#20

Base on cwhittle finding, I went into WP > Auth0 > Settings > Advance and enable the option Auth0 Implicit flow. We are now able to logon.