Blank page when redirect to <domain>.auth0.com/u/login

I’ve been trying to upgrade to the auth0-spa-js package using the redirect option from our current implementation using Lock with a pop up.

Consistency, my users and my self will be redirect to https://.auth0.com/u/login?state= and it will be completely blank on screen. If I click on another tab and the come back, the page will render. It will not render without leaving and returning to the page.

Browser: Chrome
SDK: auth0-spa-js
Implementation: Based on example with React (Auth0Provider)

5 Likes

Same issue here, using the same configuration. Is there a solution to fix this?

having the same issue.

Likely the same problem reported here:


and here:

@HLR sounds somewhat similar, but for me, I don’t even get the blank header bar, the screen is completely blank.

I’ve seen some talk in the github issue’s page about the possibility of getTokenSilently being called multiple times could cause this, but I haven’t had a chance to investigate that.

1 Like

Did some tests and getTokenSilently is only called once on my side and still causing the issue.

Also, I forgot to mention that I get an error when the login page loads :
Uncaught TypeError: Cannot read property ‘getAttribute’ of null

We’re having the same issue of getting stuck to on a blank page on our auth0 domain when logging in. The only additional (although probably not helpful) information I can add is that opening the browser dev tools also seem to cause the page to render correctly…

Exactly, I’m experiencing the same thing…
Do you also have a javascript error when you open the dev tools?

I do, but I can’t recall what it says of the top of my head, and I only get this problem sporadically and I am unable to reproduce it at will, i.e. the worst kind of problem :anguished:

@reactivv I also receive that same error. Even with that error, if I switch tabs and come back, it renders correctly.

it will render as well if you resize the browser, i dont see any error in the console.

I’m also seeing the same symptom where the page eventually renders if you just switch tabs or resize.

In my other thread, I’ve been able to solve this problem by using the new ‘Universal Login’ but realize that might not be feasible for all.

Thanks! I thought I had tried that, but I will try it again.

Hey !

I’ve got the same issue, but it is not systematic.
I’m using the New Universal Login with auth0-spa-js SDK (but I think that’s not the point of the issue).
Sometimes after users log out, there is a blank page and resizing window is sufficient to bring up the login form again. It is not very comfortable for our users.

Raphaël

Hello!

We are also experiencing the same problem. The login page after redirect is completely blank and you need a hard refresh of the page to make it work.

It’s problematic both for our users and our functional tests. I would love to hear how to solve it or when it will be solved.

Cheers

Is there a solution for this yet? We have been facing this blank screen problem for quite sometimes now.

In a desktop, the media query for max-width 480px is executed, despite my zoom level being 100%. Whenever this happens we get the blank screen. On resizing the browser, this media query breakpoint is gone and the login screen is loaded. Any solution for this from the Auth0 team?

1 Like

Same issue here. Intermittently blank screen. Resizing the browser window fixes it. auth0 team can you comment?

Piling onto the thread cause I am seeing this also in the iOS SDK. Pressing the refresh button fixes it usually, but it’s not shippable like this…

I’ve been seeing the same thing for the last month or so - when the SPA redirects to auth0, I get a blank screen about 50% of the time. Resizing the window makes the login form come up. 6 weeks and no response from the auth0 team on a deployment-blocking issue that is affecting multiple people is very disappointing.