Auth0 Home Blog Docs

Authorization Extension: An internal server error occurred

authorization-extens

#1

if everything ok on your side?
I couldn’t authenticate from my app.
Also, I’ve tried 01_login angular app - same result. Got this in console:

{
  error:"unauthorized",
  errorDescription:"Authorization Extension: An internal server error occurred",
  state:"Ei58mph28dThT0ezZsdnTlUiIk3AEdzy"
}

is “Authorization Extension” part of service and cannot be uninstalled?
I’ve tried several time, after refresh it is shown as installed.


#2

You should be able to uninstall the extension, if the uninstall process available through the dashboard is failing for you and the extension keeps reappearing you may to try to remove the underlying webtask. If you go to (https://manage.auth0.com/#/tenant/webtasks) you have instructions on how to configure the Webtask CLI to connect to the webtask container associated with your Auth0 tenant and where the extension is running. Using the CLI you can then list the webtasks, find the one associated with the authorization extension and remove it.

Have in mind that the above is an advanced mode procedure and you should it only if you are comfortable with all the steps. In addition, by default the authorization extension will only affect end-users if you publish the associated rule, so a quick workaround so that authentication is not affects is for you to disable the rule manually if you haven’t done so already. If you’re not intending to use the extension then disabling the rule should be the first thing to try.


#3

Can I get more details on how you do this from the dashboard and/or the Webtask CLI?

From the dashboard I’ve tried going to the Extensions tab and the ‘Installed Extensions’ tab and then trying either the gear icon or the trash-can. The gear-icon stays with a ‘Loading…’ and doesn’t resolve. The trash-icon asks if I want to remove it, but then returns without any change. Is there another route from the dashboard?

For the Webtask, I went to https://github.com/auth0/wt-cli and did the installation. I then tried to use the commands in this Auth0 community post: https://community.auth0.com/questions/662/im-unable-to-uninstall-authorization-extension-and. The problem is that it claims there are no webtasks. I did create and delete one following the instructions on the Webtasks of the Tenant Settings. Its possible that I don’t have the profile name entered correctly, but there doesn’t seem to be a way to globally check via the CLI for all tenants that are close to our name.
(( also verified that the Container listed after wt init does not have any active webtasks, despite the dashboard still listing the extension as installed; does this mean that the wt init is linked differently than the dashboard? ))

update: for anyone else facing this – the dashboard didn’t show that it was uninstalled, but when I forced it to reinstall, it did finish up the uninstall and re-installl from that point – also this does seem to have fixed the problem with the error messages we were getting from the web task server.


#4