Overview
When the Auth0 Authorization Extension is used in the user login flow, the user gets the following error when trying to log into the application:
authorization extension: esockettimedout
When the tenant administrators try to open the Auth0 Authorization Extension to troubleshoot, they get the following error when the extension loads the roles:
The AWS Access Key ID you provided does not exist in our records
Applies To
- Auth0 Authorization Extension
Cause
The Auth0 Authorization Extension is configured to use Amazon S3 as the storage provider, and the configured Amazon S3 key or secret has expired or been invalidated.
Solution
Update the Amazon S3 key/secret to a valid one:
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Go to the Auth0 dashboard, select Extensions, select the Installed Extensions tab, click the three-dot button on the right of the Auth0 Authorization extension, and select Settings, as shown below:
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In the Configure Extension window, update the S3 key and S3 secret accordingly, as shown below: