Auth error: Unable to verify transaction consistency

We have a huge problem in Pro, it seems that without changing anything from near yesterday midday (Italy) the authentication is returning an error error=unauthorized&error_description=Unable%20to%20verify%20transaction%20consistency

Can’t understand what to do. We are using the EU tenant. Users can’t neither login nor signup. Is there someone can look at this issue?

1 Like

We also have this problem, which started happening within the last one day or so. Nothing has changed on our platform recently. We are using a US tenant.

The authentication flow in some scenarios requires a series of requests instead of one single request; in such situations the server may trigger that error if one of the requests in that series demonstrates inconsistent characteristics when compared to the ones that happened before. In general, this series of requests are performed in a very short time frame and all coming from the same source so the likelihood of inconsistencies is small, but it can happen.

Unfortunately when this happens in most cases it’s an issue with how the client-side is behaving and related to which information is sent as part of those requests so in order to troubleshoot this situation an HTTP trace will be required for the complete authentication flow that results in those errors (be sure to redact sensitive information like passwords before sharing the trace).

I think it is not related about you mentioned the cause of client-side behaving and inconsistent characteristics.
We used normal user account when we login, but not include specific characteristic of username.
That url shows _ XXXerror=unauthorized&error_description=Unable%20to%20verify%20transaction%20consistency&state=eyJhdXRoTWV0aG9kIjoibG9naW4iLCJwYXRobmFtZSI6Ii8ifQ%3D%3D

Not go to the our homepage. And then, I tried to login two times or three times , It works again.
We have never seen this problem like this before. It happen start from last week.
Please look at this issues and hopefully fixing as soon as possible.

I saw that only users with username-password connection were involved, before the issue I was already working on remove the old login and password method (the one will be deprecated) and replace it with resource owner password grant, I finished the migration and I saw that my changes solved the problem (I don’t know exactly how/why).
Hope it could help.


Thanks for your help. I think it works! :slight_smile:

I also have had this exact thing started happening. I only noticed in the last hour or so. Absolutely nothing has changed on the client or server side, but clients are getting a “Oops, something went wrong” message and the logs are saying “Unable to verify transaction consistency”. This particular client and server code has been working flawlessly for ~2 years now. Any idea what has changed on auth0’s end? This is using lock v9.

1 Like

We also encountered the same problem. I keep getting the error ‘unable to verify transaction consistency’ during the callback.

No code has changed for over a year an the user name password sudden stoped working.
Verifing with facebook still works fine.

We use the embedded widger and I tryed upgrading to lock 11, but the error is still the same. Up on receiving the call back we get the error.

Anyone that can help is much appreciated.


Hey there!

Sorry for the delay in response. We’re doing our best in providing you with best developer support experience out there, but sometimes there are too many questions to handle. Sorry for the inconvenience!

Do you still require further assistance from us?

we fixed the problem upgrading auth0 on April, thank you anyway :wink:


Perfect! Glad to hear that!