Auth0 Home Blog Docs

API created User delete not working



Environment: develop;

API version: V2

Steps to reproduce:

  1. SignUp using email1 (E1)
  2. Create user via API with email 2 (E2)
  3. (optional) Link (E2)into one identity (E1), unlink E2 from E1
  4. Never signIn with user (E2)
  5. Delete user (E2). API returns httpCode 204
  6. User E2 is still visible in and unaccessable (see attached image)

![alt text][1]


The Dashboard page you linked to makes use of user search functionality which already contemplates some delays in surfacing actions performed to the user which under normal circumstances could explain the issue if for example you immediately navigated to the search page after having deleted the user . On top of that and as noted in the status page we are currently experiencing some issues with the user search functionality that may magnify the delay.

Having said that, there may be a different issue associated with your exact steps, however, trying to reproduce the situation right now would not deliver definitive information as the current issues would impact our observations.

If you have the user identifier of the user in question you can perform a GET /api/v2/users/{id} which should not return a user and that would be another indication that it’s a search specific issue that may be resolved after the current issues are addressed. You can subscribe for updates through the status page and if your situation persists after the current issues are addressed you can leave a comment here. Apologies for this situation.


This problem apparently resurfaced. It has worked till couple of days ago… Using standard database. Adding Demo users by CREATE…user is added but trying to delete from Dashboard gives no error but user still not deleted. issuing a delete in Postman gives error 404…Getting List command shows user still there as well.

The deleted users continue to show as listed under dashboard and on GET list commands. However, clicking on the user in the dashboard says user not found

I believe this is a bug


I’m experiencing a similar issue as well. Users were created then later deleted via API, but persist in the Dashboard well over 5 hours post deletion. I’m experiencing this issue on a free account used for testing.


There were some indexing delays around the timeframe you posted that could explain the issue, however, those are now resolver so if yous till experience the issue then the root cause is something else. If the issue still occurs you’ll need to share the tenant/domain where this happens and the end-user in question if possible (for example if it’s a test user).


If the situation persists after five hours it’s unlikely to be related to any indexing delay, however, to troubleshoot this situation you’ll need to share the test tenant/domain where this happens and the test user in question.

![alt text][1]

Clicking on any:
![alt text][2]


FYI, I am not on Free account


Thanks for providing that information. Just as a separate note have in mind that if you have a paid subscription you can choose to create support tickets which would mean you can easily share private information. I’m saying that because even though those seem test users they still have real email addresses. In relation to the issue itself I’ll need to do some checks, but can you also let me know how did you go about deleting those users? Did you do it through the dashboard, management API?


Deletion was through the dashboard as I recall


Deletion was through the dashboard as I recall


@safadig you should have received a message through another support channel; if you have then you technically don’t need to respond in either places and an update will be provided when additional information is available. If you did not received it then let me know here.