Allowed Logout URL not recognized -- Going through Auth0 Ruby on Rails SDK Quickstart:

I’m going through the [https://auth0.com/docs/quickstart/webapp/rails/01-login](http://Ruby on Rails Auth0 SDK quickstart) and the only thing that isn’t working is the whitelisting of the URL that should be redirected to after a successful logout.

I can log in, and the logout link clears the session, but always brings me here and tells me my returnTo parameter is not defined in “Allowed Logout URLs”:

except it clearly IS defined and I’ve tried removing the trailing slash and other silly things. What am I missing here?

thank you for any help. I’d really like to get started with auth0 and this trial run is messin with my vibe. :slight_smile:

Hi @pdbradley, welcome to the Auth0 community!

Have you tried without the trailing slash? I.e. http://localhost:3000

@kstrongholte I did, and to no avail.

However, I just downloaded the “prefilled” rails app that the tutorial offers (prefilled with my own creds) and…it works. so I must have configured something wrong as I followed the steps. I just went through the one I did by hand and compared it carefully with the pre-filled and I don’t see any difference, but it is there, and I need to pay the price to find it.

So at least I know I’m probably the culprit.

thanks

No worries! It happens to the best of us.