Auth0 Home Blog Docs

Have trouble logging out - Bug in Auth0?

In my application settings, under Allowed logout URLs I have entered “https://localhost:5001/

But when I then try to logout, I get this error:

The “returnTo” querystring parameter “https://localhost:5001/” is not defined as a valid URL in “Allowed Logout URLs”. To add a new URL, please do it here: https://manage.auth0.com/#/account/advanced

TRACKING ID: 8dc2209630d64ae65386

In the raw log output, there’s a section:

“details”: {
“return_to”: “https://localhost:5001/”,
“allowed_logout_url”: [],
“session_id”: “owKFZIquCnu6RaD4RTNMsSBOBIjRlsLr”
},

And I was surprised that the allowed_logout_url array is empty, should it not list the URLs as defined in the configuration?

Hey there @tore!

It should be working. Can you send me via private message the screenshot of your Allowed Logout URLs for that client?

Thank you!

Another try

The “returnTo” querystring parameter “https://localhost:5001/” is not defined as a valid URL in “Allowed Logout URLs”. To add a new URL, please do it here: https://manage.auth0.com/#/account/advanced

TRACKING ID: e6d1b9e7710f1ed2b405

So I am confused why the Allowed_logout_urls is empty in the log entry below

{
“date”: “2019-06-18T14:16:24.220Z”,
“type”: “flo”,
“description”: “The “returnTo” querystring parameter “https://localhost:5001/” is not defined as a valid URL in “Allowed Logout URLs”. To add a new URL, please do it here: https://manage.auth0.com/#/account/advanced”,
“connection”: “Username-Password-Authentication”,
“connection_id”: “con_BeUeQZrUjZVZvlP3”,
“client_id”: “aGfTSM8LyHALI8f7UR4mtT1uLspe0UJS”,
“client_name”: “ManualOpenIDConnect”,
“ip”: “83.219.207.134”,
“user_agent”: “Chrome 74.0.3729 / Windows 10.0.0”,
“details”: {
“return_to”: “https://localhost:5001/”,
“allowed_logout_url”: [],
“session_id”: “owKFZIquCnu6RaD4RTNMsSBOBIjRlsLr”
},
“hostname”: “edument.eu.auth0.com”,
“user_id”: “auth0|58204d4ab6c8bb007f99b73f”,
“user_name”: “demo@edument.se”,
“log_id”: “90020190618141624220865981800901979475522222467928031250”,
“isMobile”: false
}

I am currently just experimenting with OpenID connect and the various flows, just to understand it all.

Best regards

Thank you for all that context! I’ll get back to you once I research it!

I just sent you a private message. Let’s keep the conversation there and then we’ll share the solution with the community once we work it out!

Solution

Call logout with the client identifier of that application otherwise the URL needs to be added at the tenant settings.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.