Auth0 Home Blog Docs

All Auth0 requests routed to 127.0.0.1 and failing

failed-login

#1

For one of my tenants, all requests are getting DNS routed to 127.0.0.1 and failing. Here’s command line diagnosis:

deshao ~> dig A tty1.auth0.com > > ; <<>> DiG 9.10.3-P4-Ubuntu <<>> A > tty1.auth0.com ;; global options: +cmd > ;; Got answer: ;; ->>HEADER<<- opcode: > QUERY, status: NOERROR, id: 30263 ;; > flags: qr rd ra; QUERY: 1, ANSWER: 1, > AUTHORITY: 0, ADDITIONAL: 1 > > ;; OPT PSEUDOSECTION: ; EDNS: version: > 0, flags:; udp: 512 ;; QUESTION > SECTION: ;tty1.auth0.com. > IN A > > ;; ANSWER SECTION: tty1.auth0.com. > 299 IN A 127.0.0.1 > > ;; Query time: 478 msec ;; SERVER: > 8.8.8.8#53(8.8.8.8) ;; WHEN: Tue Oct 24 23:44:27 EDT 2017 ;; MSG SIZE > rcvd: 59

Please note my other tenants are working properly, e.g.:

deshao ~> dig A eshao.auth0.com > ; <<>> DiG 9.10.3-P4-Ubuntu <<>> A > eshao.auth0.com ;; global options: > +cmd ;; Got answer: ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: > 21481 ;; flags: qr rd ra; QUERY: 1, > ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 1 > > ;; OPT PSEUDOSECTION: ; EDNS: version: > 0, flags:; udp: 512 ;; QUESTION > SECTION: ;eshao.auth0.com. > IN A > > ;; ANSWER SECTION: eshao.auth0.com. > 59 IN A 54.191.106.157 > eshao.auth0.com. 59 IN > A 52.88.152.218 eshao.auth0.com. > 59 IN A 54.213.224.177 > > ;; Query time: 312 msec ;; SERVER: > 8.8.8.8#53(8.8.8.8) ;; WHEN: Tue Oct 24 23:44:32 EDT 2017 ;; MSG SIZE > rcvd: 92

Note that this prevents all users from logging into my app as the https://tty1.auth0.com/authorize endpoint is routed to 127.0.0.1


#2

handled through another support channel, providing a summary here

This situation was due to an abnormal amount of repeated requests that were perceived as automatic testing although it was coming from a client application that experienced a glitch. The block should now have been removed after receiving confirmation that the issue in the client application was addressed.


#3