Zendesk SSO Integration Not Working: "Callback URL mismatch" Error

Last Updated: Dec 3, 2024

Overview

This article explains a potential cause of the following error when trying to use the Zendesk SSO integration:

Callback URL mismatch. https://(Zendesk Account Name).zendesk.com/access/saml is not in the list of allowed callback URLs

Troubleshooting

Check the tenant logs for the domain name used for the callback URL.

Applies To

  • Zendesk

Cause

One Zendesk account can have multiple Brands: Setting up multiple brands.

  • Each brand has its subdomain.
  • If a brand’s subdomain is mistakenly used for a Zendesk Account Name while creating a Zendesk SSO Integration in the CIC tenant, it will not work.
  • The Zendesk Account Name has to be set to the main/parent domain.

Solution

Use the main/parent domain as Zendesk Account Name.