Auth0 Home Blog Docs

Why am I not asked how I want to log in?


#1

I am using Auth0 in my app. It’s working. I set it up to use two social providers, Google, and Github, and I was able to login with Google. But the next time I want to log in, I click the button on my site which forwards me to the /authorize route on auth0.com, and it immediately forwards to my callback URL. As in, I’m already logged in… it won’t let me switch from logging in via Google to logging in via Github.

The odd thing is, this happens not just with my app but with Auth0’s site itself. If I visit the auth0.com homepage and then click the Login button, I’m immediately forwarded to manage.auth0.com. It doesn’t ask me how I want to log in (via Google, Github, etc).

Any ideas on why?


#2

In case it matters to Auth0 admins/staff, I’m asking on behalf of one of my students. The problem I’m describing does not happen to me. (But of course I want to understand the situation) So perhaps it’s some kind of configuration that I’m not aware of?

But it can’t be application configuration because it happens even with logging into the Auth0 dashboard itself.


#3

To try to determine if it’s something with her application that she built or with her Auth0 account/tenant, I tried visiting her website from my computer. I received an error about a callback URL mismatch, so we of course went into her Auth0 application settings and tried to set the allowed callback URLs to include http://192.168.1.71:3000/callback, but when we pressed Save, Auth0 showed an error message at the top of the page saying “Forbidden”, with no other information.

Do you know what the Forbidden means? (We didn’t change any other settings) Why wouldn’t I be allowed to use http://192.168.1.71:3000/callback as a callback URL?


#4

Can anyone help? Is my question clear, or should I update it in any way to provide more detail? Help is appreciated, thanks!!