Auth0 Home Blog Docs

When using Azure AD connection, only email text box is shown; no response on login



I have an Azure AD connection set up and when I run the connection from the Enterprise Connections dashboard, it works as expected.

However, when I integrate the application, what I’m seeing is a single text box with an email icon next to it. When I type in the email, I can see two requests go out to Gravatar (both return 404 since my test user does not have a Gravatar account), but I do not see any requests or errors otherwise. When I click LOG IN, no action occurs and no requests are generated. If I use an email address with a known Gravatar account, the requests return 200 and the avatar updates, but still no action on LOG IN.

I have verified the clients from the Enterprise Connection client configuration page to make sure it is enabled.

I have also verified that the client Connections tab that the connection is enabled.

Tested first with IE9, then with FF current; same behavior in both cases. Traced with Fiddler as well as the built in dev tools; only the Gravatar requests are going out.

Any hints?


Got it. The connection did not have a domain alias associated with it so nothing was triggered when I clicked LOG IN.


Hi Charles.
Newer versions of Lock now show a message that gives a better clue:


The default (non-customized) hosted login page currently uses an older version of Lock that is not as intuitive (as you found out). I’ll make sure this is corrected.

Thanks for the heads-up!