Welcome Email Templates not Sent for OIDC Connections

Problem statement

This article explains why welcome emails are automatically sent for Social and database connections but not for OIDC connections.

Symptoms

Welcome emails were not sent for some connections.

Steps to reproduce

  • Create an Enterprise connection, such as an OIDC connection
  • Log a user in for the first time via the newly created Enterprise connection and notice how the Welcome email is not automatically sent.

Cause

Welcome emails are not sent for Enterprise connections, and this is by design. They are supported for Database and Social connections, which are more B2C oriented.

Solution

Sending Welcome emails for Enterprise connections is not supported as this behavior is by design. There are some workarounds to this, such as:

  • Customizing the verification email template to make it functional as a Welcome email and trigger it via the API upon Enterprise connection first login.
  • Leveraging app metadata or login count.
    • For example, a field in metadata like “welcome_email_sent”: true/false. The application could read that data and send an email on the application side if needed. If the customer’s welcome email is simple onboarding instructions without any requid syntaxes, this approach might work. The email templates have access to the user’s metadata, so it is possible to read the metadata from the verification email template and display a different message depending on its value, such as:
{% if user.user_metadata.send_welcome_email== 'true' %} Welcome, ...