Overview
This article explains how to use a passwordless email connection with the Device Authorization Flow and provides a solution for the error below that may occur during this configuration.
no connections enabled for the client
Applies To
- Device Authorization Flow
- Passwordless Connections (Email)
- Auth0 Dashboard
Cause
Even though the Call Your API Using the Device Authorization Flow documentation might not explicitly state it, passwordless connections can be used with the Device Authorization Flow.
The “no connections enabled for the client” error occurs because the authentication flow does not know how to handle a passwordless-only setup without a specific configuration. When using passwordless connections, the login flow must first prompt for the user’s identifier (email address) to determine where to send the one-time code. The Identifier First profile configures the Universal Login Page to request the email address first and then direct the user to the correct passwordless method. Without this setting, the system cannot determine which connection to use.
Solution
Enabling the Identifier First authentication profile in the tenant resolves the “no connections enabled for the client” error and allows you to successfully use a passwordless email connection with the Device Authorization Flow.
- Go to the Auth0 Dashboard.
- Navigate to Authentication > Authentication Profile.
- Select Identifier First.
- Click Save.
This configuration prompts for the email address first, which allows the system to correctly handle the passwordless flow.