Users Not Receiving Passwordless SMS from Twilio

Problem statement

Passwordless SMS users are not receiving any text message with a code to enter.

Cause

This may be due to a misconfiguration on the Auth0 side or on the Twilio side.

Solution

In the tenant logs, the type: “cs” log type shows that login attempts are correctly triggering the Passwordless login code. Auth0 calls the Twilio API upon a login, and if the API returns a 200 result, a log of type cs will be created.

Check to see if there is a failed login log after this and see what the error description is. If an incorrect Twilio SID or Twilio AuthToken is used in the Passwordless SMS settings, a user never gets an SMS message and the tenant log records a Type: Failed Login, Description: Failed to send sms notification error. Oftentimes the error description will include an error code from Twilio that can be used to find the appropriate troubleshooting guide on their side. For example, the error description “Authenticate (Code: 20003)” comes from Twilio and has a troubleshooting guide here.

However, if there is a misconfiguration on the Twilio side and Twilio does not send back any errors to Auth0, there will not be an error message in a tenant log, and the next step would be to review the logs on the Twilio side.

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