Username/password authentication does not seem to work?

Hi,
For my internship, I need to make postman tests to test the application in an Azure devops pipeline.
I want to log in with username and password and receive a token from auth0 without using the web interface. I found this https://auth0.com/docs/login/embedded-login/cross-origin-authentication, but I am not able to get it to work. When I try this endpoint co/authenticate I get this:


Then I tried it with this endpoint oauth/token and I get this:

For both, I use a Regular Web Application and I enabled password grand type for it.

I figured out how to do this for a device like this:


And I want to be able to do the same thing but then for a user. Is this possible and how?

Hi @diede,

Welcome to the Community!

To follow the resource owner flow without a web interface, you can follow the guide here:

Here is an example request:

Screen Shot 2021-04-28 at 11.29.02 AM

You will also want to make sure that your tenant has a default directory set to the connection name (Tenant settings > General → API Authorization Settings ->Default Directory)

Related topic:

1 Like

Thank you! That worked!