User not Assigned to the Client Application Error at Log In

Overview

This article explains why the following error occurs when users attempt to log in to an application using an external Identity Provider (IdP):

error=access_denied

error_description=“User is not assigned to the client application.”

Applies To

  • External Identity Provider (e.g., Okta)

Cause

This error indicates that the affected users are not assigned to the client application on the Identity Provider.

Solution

To resolve this issue, assign users to the appropriate client application in the IdP console. The IdP Client ID can be found in the Auth0 dashboard by navigating to the appropriate connection’s settings.

For example, if Okta is the Identity Provider, refer to the Okta documentation for How to assign a user to an application in Okta.