Policy Evaluation Error on Enterprise OIDC Connection

Overview

This article explains the following error that might occur with an enterprise OpenID Connect (OIDC) connection:

access_denied error: “Policy evaluation failed for this request, please check the policy configurations.”

Applies To

  • Enterprise OIDC Connection
  • Policy Evaluation Error
  • Access Policy

Cause

When Okta is the Identity Provider (IdP) for the connection, this error indicates the access policy for the client application does not allow the scopes requested.

Solution

To resolve this issue, one of the following actions must be taken:

  • The IdP administrators must update the access policy to grant the scopes requested by the connection.
  • The scopes requested in the OIDC connection’s configuration must be changed to align with the access policy.

Related References