Universal Login with Social

Hi, I have configured two social network connections (Facebook, LinkedIn), however when I go to preview the Universal Login box, it shows me only Google. Is this how it’s supposed to be because it’s a preview or am I doing something incorrectly? Thank you.

Hello and welcome to the Auth0 Community!

When you click on “Preview” in the Universal Login settings, it should show you the social connections which you have enabled for your applications. However, if a social connection is configured, yet no applications are enabled for it, then the social connection will not be displayed in the login preview.

On the dashboard, when you go to Connections > Social, is there at least one application enabled for Facebook and LinkedIn?

Please let me know if this is not the issue!

Thanks,
Stephanie

2 Likes

Thank you, Stephanie.

So I do have one of my applications (SPA) enabled for both social connections. When I go to Universal Login->Login->Preview, there is a drop down which says “APPLICATION”. However when I try to choose the enabled application from the list, nothing happens and the drop down continues to show “APPLICATION” instead of the specific application I am trying to choose.

I sent the same through email, but I received a notice that it didn’t go through for some reason.

Hm, it looks like the label for “Login->Login->Preview” will walways be “APPLICATION” when different applications are selected.

There is another way to test the universal login page. You can click on your tenant name on the top right corner of the dashboard. A dropdown will appear. Click “Getting Started” and then click “Try it out”.

If you have already logged in and you see “It Worked!”, then you’ll need to first logout by navigating to this URL: https://YOUR_DOMAIN.us.auth0.com/v2/logout?federated (replace YOUR_DOMAIN with the domain value found in any of your applications’ settings.)

If you go to Connections > Social > Facebook or LinkedIn > Applications, and you have the toggle turned on for your SPA, then you should see the social connection in the universal login page when you go to “Try It Out”.

Ok, I tried the second method for testing and still see the same result (only Google, as opposed to the two I have configured).

Also, when I try to sign up with an email and password, I get the following cryptic message. Maybe the two issues are related?

image

It could be related. Would you mind sending the error message you get in your console when you see the [object Object] error?

It might be related to how the Universal Login is configured. To see if that is it, you can set it to a default version by going to “Universal Login” in your dashboard. Select the “New Universal Login” option and click “SAVE CHANGES” at the bottom:

And then click on “Login” and toggle off “Customize Login Page” (the editable HTML code will be disabled, but any changes made will be saved if you want to turn customization back on later)

You can then check the “Try it out” link to see if your connections are there.

Not sure where this console is, sorry.
Also, I followed the instructions (New / toggle off Customize) but I no longer see an option / link to “Try it out”. Please advise. Thx

No problem! Click on the top right menu and then click “Getting Started” and then click “Try it out”

screenshot-manage.auth0.com-2020.12.22-07_10_29

1 Like

Thanks, that partially worked. It showed the correct social auth options, but when I tried to signup (just email/pw), it went to a blank page (URL below) with a message “connection not found”. I am not sure what that means and why it has google-oauth2 in the URL (maybe a generic protocol?).

https://manage.auth0.com/tester/callback?connection=google-oauth2&code=yOBonQoje1dDz_u_

Hello, sorry for the delayed response!

Would you mind sending the error message in text for the URL you sent (I just get an unauthorized error since the code is only valid for a brief time)?

I am not sure why google-oauth2 is in the URL as the connection, I’ll have to look into that some more. You are probably right about it being the default connection.

Is the database connection enabled? That allows users to sign in with a username/password. To check, go to Connections > Database and click “Username-Password-Authentication” and click on the applications tab to see if applications are enabled.

1 Like

Hi, the error message is the same I sent before - “connection not found”

The URL which shows this is - https://manage.auth0.com/tester/callback?connection=google-oauth2&code=[code redacted]

And yes, I do have a Database connection configured, it works and all my applications are enabled for it. However, when I try to display the Universal Login, I get redirected to the above URL with the message “connection not found” and nothing else (no HTML, just this text).

It looks like this error occurs with the “Try it out” link if you do not have Google as a social connection in your tenant at all. The error does not occur in my actual application using the Universal Login, only the test link that launches from the dashboard.

If you add Google as a social connection but disable all of your applications from using it, you should be able to use the “Try it out” link with the login form.

To add Google as a social connection go to Connections > Social and click “+ CREATE CONNECTION”, click on “Google / Gmail”. Click continue to authorize Google. You do not need to add any keys, just click “CREATE” at the bottom.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.