Universal Login page localized error messages

I have customized our Universal Login page.
My tenant default (and only) language is Dutch.

When a user enters faulty credentials the error message returned is in English.
When I customize the prompts text (for instance, login.wrong-email-credentials) via https://[tenant].eu.auth0.com/v2/prompts/login/custom-text/nl it will not show up.

Hi @bvanolphen,

I tried to reproduce this but in my test I got back the correct customised error message with my tenant configured to only use Dutch.

Could you please share in cURL format the command you used for the Text Customisation API to add in your changes, but please remove/redact the bearer token from the cURL prior to sharing here.

1 Like

I’ve used the following with Postman:

PUT https://{{auth0_domain}}/v2/prompts/login/custom-text/nl
with body
{
“login”: {
“wrong-email-credentials”: “Uw email of wachtwoord is incorrect.”,
“user-blocked”: “Uw account is geblokkeerd, een email is verzonden aan dit account.”
}
}

When I send this command I get back status 200 with the same body.

When sending with Postman a GET https://{{auth0_domain}}/v2/prompts/login/custom-text/nl I get back the same body as above.

Is there something I have to add in my Universal Login page?

The command looks correct to me, therefore there may be a misconfiguration with your tenant as I used the exact same PUT and could see both custom messages being shown at the relevant point.

Have you made any customisations to your login page code? If so this will make the login page revert to the classic universal login behaviour (1st bullet point here), and the Classic experience doesn’t support the Text Customisation API. Please make sure you have not enabled customisations for the login screen (https://manage.auth0.com/#/login_page)
If you are still having issues could you please share a screenshot of the issue occurring and let me know your tenant name in a DM?

1 Like