Auth0 Home Blog Docs

Unable to sign up new users

wordpress
custom-db
signup

#1

Hi,
we’re all of a sudden having problems signing up new users.

We use the Auth0 WordPress plugin with a Custom DB to handle users.

The “Logs” section of Auth0.com says “Failed signup” with the error description Unexpected end of input.

After some troubleshooting we found that for our Custom DB (named DB-Life-with-Kids) only have a Login and Get User Database Action Scripts, we’re missing the Create and other scripts, is that normal?

Also, when we try to sign up a new user (for instance using the “Try connection” on Auth0.com for our Custom DB, we just receive a HTTP 500 with the response ‘{“fromSandbox”: true}’.

We can still sign in users via the same Custom DB. The last time we were able to sign up a user was on July 2nd. To my knowledge we haven’t done any changes on the Auth0.com (or WordPress) side for this to stop working.

Please help us get back to being able to sign up new users.


#2

Some additional information.

We don’t have any “Rules” enabled.
We’ve been using Auth0 in this capacity for a year and a half without any mayor problems.


#3

Sorry for the trouble here, @peralmq.

When you try that in the plugin, do you get an error on your WordPress site or in Auth0? Are there any errors in the plugin error log? You mentioned Rules but do you have any Hooks active?

The custom scripts are there to authenticate a user if there is one. If not, that’s a create action, which is automatic in Auth0. That create user action in Auth0 should redirect back to your WP site’s callback URL with a code and state parameter, which the plugin uses to find the user data and either log the person in (which, on signup, would not happen) or create the user.


#4

Has this been resolved?

Same for me, sometime since WP Auth0 sign up fails, Auth0 logs “Unexpected end of input”.

Last successful sign up was 8 days ago on 1st July 2018

WP error.log and ssl_error.log do not show any errors.

WP Auth0 logs do not show anything.

Might it have anything to do with “Your tenant has the Legacy Lock API enabled.”?


#5

Resolved it by updating IP Addresses in Advanced page of WP Auth0 plugin to be:

52.28.56.226,52.28.45.240,52.16.224.164,52.16.193.66,34.253.4.94,52.50.106.250,52.211.56.181,52.213.38.246,52.213.74.69,52.213.216.142,35.156.51.163,35.157.221.52,52.28.184.187,52.28.212.16,52.29.176.99,52.57.230.214


#6

@DeafJoe - Thanks for posting back with the resolution here! Is this in the “IP Ranges” field with “Enable IP Ranges” turned on? We have valid IP addresses hard-coded in the plugin, those might need to be updated. I’ll look into that internally.

@peralmq - Let me know if this doesn’t solve your issue.


#7

In WP Auth0 / Settings / Advanced:
I have “Migration IPs Whitelist” enabled
and it was in the box below “IP Addresses”
that pasting the new IP list and Saving fixed the Sign Up.

The IP list came from the Outbound Calls / Europe section of the Auth0 / Documentation / Rules / Overview page at: https://auth0.com/docs/rules/current


#8

Yes, that solves it!

Updated the IP Addresses as @DeafJoe suggested and now sign up works splendidly. :raised_hands:

Thanks to both of you for the time spent <3