Unable to change user password

I tried to change user password from users > user details > actions > change password

After entering new password twice I click save and get the following message telling me “email or username required”. :


Can you tell me why I am unable to change the password for this user

1 Like

Hey there @prod-wras!

Can I ask you two things?

  • I will need you to send me your tenant name over private message
  • Record me a HAR file and send it to me via private message to cover the whole process starting from opening users section in the dashboard. Here’s how to capture that:

sure, can you please tell me how to send you a private message?

When you go to someone’s profile there’s the blue message button in the upper-right corner.

Thank you a lot for sending the HAR file!

After initial inspection you’re getting a 400 (bad request) status code when patching user password. It seems like there’s a problem on our side.

I reached out to our Dashboard team to see what might be the reason of that. Can you in the meantime send me your tenant name over private message?

Thank you!

Can you also provide us with the info whether the issue occurs for every user or just this one?

Hey there!

Friendly ping :slight_smile: Have you had a chance to see my last message?

We’re still investigating it with @prod-wras but it seems like individual scenario. Will let you know in the thread what was the reason once we get there!

Not isolated. Happening with us too and other companies - but there’s no universal place to report bugs. We looked on twitter before finding this forum.

Same issue: getting a static error when trying to update a user’s password via the management dashboard:

{“statusCode”:400,“error”:“Bad Request”,“message”:“email or username are required”,“errorCode”:“auth0_idp_error”}

users > user details > actions > change password

Or from link at bottom of page with actions. same result from both places

We’ve found another account getting the same error. We’ve tested over 10 accounts and only 2 users got the error. We’ve also carefully checked their profile but can’t find anything special.

We could try Management API but even it works our end user (administrator of the application) will not be able to run API…

Totally get it thanks for reporting that! They won’t be able to run the API but we will be able to evaluate which part of the stack is not working on our side for those two users

I just got the information from the team that there was indeed some error discovered and they’re working on a fix. in the meantime here are the ways to fix it:

  • Ask user to login if possible
  • Recreate the user

I"m also seeing this same issue with the management API. A user that we recently created the past couple of days is having this same issue. Any ETA on when the fix will be implemented?

Let me circle back with the team to see what are the approximate dates!

Hey there @bmikinski!

Need you to send me via private message your:

  • tenant name
  • user_id or email you are trying to change the password and having issues

Thank you!


Any update on the fix? our client is getting really frustrated and refusing to use Auth0 console. We’ll have to now build a custom user management using management API or seek for another solution. If the management API is also getting the same error, we’ll not be able to provide a reliable custom user management.

Please let us know so we can determine…

Hey @prod-wras!

Our dashboard team is debugging it with the info I asked for that we received from one of the customers. I’m not able to give you any ETA as they are currently working on that trying to determine the root cause. I will let you know as soon as I have any info back! Sorry for the inconvenience!

Hey there everyone!

The fix has been deployed and it should be doable now! Would be great if you can check that!