"Tenant must be specified" error on password reset attempts

Problem statement

When attempting to reset the password, we are receiving the following error:

{"name":"BadRequestError","code":"missing_property","description":"tenant must be specified","statusCode":400}

Symptoms

All attempts to reset passwords fail with the error “Tenant must be specified”

Troubleshooting

  • Using Classic Universal Login with a Custom Password Reset page
  • Network traffic showed a request to the /lo/reset endpoint, though it was using a different domain than either the canonical or custom domain configured on the tenant
  • JS script tag within the custom password reset template showing hard-coded url “https://www.NOT_AUTH0_DOMAIN.com/lo/reset"

Cause

in the Custom Password Reset template, the URL has the wrong domain when making the password reset request.

Solution

You need to update the password reset URL to use the correct domain configured on the tenant.

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