Streams Exceeded 5 second limit

I am trying to get log streaming configured. I get
“logsDelivered”: 0,
“status”: “error”,
“startingCursor”: “90020221231154307427000000000000000000000000000000000000”,
“endingCursor”: “90020221231211802744755670967176847380277912109880180898”,
“error”: {
“message”: “HTTP request to log.mydomain.com exceeded 5 seconds limit”
I’ve search and search and I can’t find anything about this 5 second limit. What is it for? Can I adjust it? Is it 5 seconds to establish the stream? Is it 5 seconds to send 1 log, to send multiple logs? What is it?

Hi @mgoauth0 ,

I noticed that you created a support ticket for the same issue and our Support team has resolved this. Here is the answer:

The 5 seconds timeout limit is not customizable. It means that the endpoint is not responding when we try to POST the logs batch, so you will need to check if the Payload URL is the correct one.

The minimum configuration for the HTTP input plugin requires two options:

  • port - To set a custom port.
  • additional_codecs - To set application/json type.

So the URL schema will be something like this: <protocol>://<downstream-logstash>:<port>.

Ref: Http input plugin | Logstash Reference [8.6] | Elastic

Hopefully, it can be beneficial to other folks in our community!