Overview
This article explains why the following error is received while trying to view an Single Sign On (SSO) Integration application configured in Auth0:
Error! Error calling getByIdentifier: Error: Request failed with status code 400
Applies To
- Dashboard UI
- Applications
- SSO Integrations
Cause
This can be caused by an application being created via the Management API and specifying app_type
as sso_integration
.
Solution
By setting the app_type
to sso_integration
, the dashboard will assume the application is one of the marketplace offerings. If this is not a registered SSO integration on the marketplace, the UI will fail to find its details, and the Error calling getByIdentifier is seen.
When creating applications manually, one of the 4 supported application types listed below should be used, the other application types should be considered for internal use by Auth0:
“Type of client used to determine which settings are applicable. Can be spa, native, non_interactive, or regular_web.”
(From: Create a client)
A breakdown of the different application types can be found here:
To allow modifying an application in this error state via the Dashboard change the app_type for the client via the Management API to one of the supported types, like “app_type”:“regular_web”
- It should then become visible in the tenant’s Applications list (not SSO integrations) and can be updated there via the Dashboard UI like any other application henceforth.
For further context: SSO integrations are a wrapper for Applications or Clients, designed to streamline the setup process by only allowing tenant members to manipulate certain settings that will need customization on a case-by-case basis whilst keeping the rest of the client settings set to the correct defaults for the intended service provider and hidden from tenant member view.
To add an integration to the Marketplace, please see the documentation here: