Social Integration: VK. Need API Update

VK Error on the TRY page: https://manage.auth0.com/dashboard/eu/dev-dsparfum/connections/social

{
  "error": "invalid_request",
  "error_description": "Invalid request: versions below 5.21 are deprecated. Version param should be passed as \"v\". \"version\" param is invalid and not supported. For more information go to https://vk.com/dev/version_update_2.0"
}
1 Like

From 1 June 2020, versions 5.20 and lower will be outdated.

Looks like auth0 uses lower version. Can someone from admins say when do they plan to fix this social integration, because now users can’t authenticate within vk?

1 Like

Hey there!

Let me dig into that and update you once I have more information on that front!

Little update.

I raised an internal ticket for that for our engineering teams. Once I have the response from them I’ll share it with you!

Good morning,

Our engineering team is working to fix this. However, we have found a workaround for you which will help you fix it for now:

You can get the connection using the management API:
https://{your_auth0_domain}/api/v2/connections/con_ID

Once you get the connection you can patch this connection with the supported API version, Example:

PATCH https://{auth0_domain}/api/v2/connections/con_ID

{
    "options": {
        "wall": false,
        "notes": false,
        "pages": false,
        "scope": [
            "profile"
        ],
        "video": false,
        "photos": false,
        "friends": false,
        "profile": true,
        "client_id": ""Sample"",
        "client_secret": ""Sample"",
        "apiVersion":"5.107"
    },
    "is_domain_connection": false,
    "enabled_clients": [
        "Sample"
    ]
}

This will update your API version, Once engineering provides a fix you can remove this field.

2 Likes

@karen1 thanks for providing a workaround, but unfortunately I can’t follow it:

  1. When I was trying to get connection via your API explorer I got 401

{
“statusCode”:401,
“error”:“Unauthorized”,
“message”:“Missing authentication”
}

  1. When I was trying to obtian an Access Token I got 403

{
“error”:“unauthorized_client”,
“error_description”:“Grant type ‘client_credentials’ not allowed for the client.”,
“error_uri”:“https://auth0.com/docs/clients/client-grant-types
}

  1. When I was trying to turn on client_credentials in Application settings I was told to set a Token Endpoint Auth Method other than “none”
    image

  2. Token Endpoint Authentication Method field is greyed and can’t be changed.
    image

My question is: What I am doing wrong and how I can make my connection work again?

Thanks.

@alexzaitzev Fixed.
@karen1 @konrad.sopala Thank you, guys

1 Like

@alexanderdomrachev great to hear that it works for you!

I am still receiving error while authenticating. Workaround also is not an option because of the reason I wrote in my prev message.

Understand that. We’ll let you know once the fix is there then!

1 Like

Looks like problem is fixed.

1 Like

Perfect! Super glad to hear that!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.