Social connection with Google not working

Have followed this guide to add my credentials. Didn’t see the “Application type” field, but the rest I’ve done as asked. On testing the connection, I’m getting this response:

{
  "error": "invalid_request",
  "error_description": "Unauthorized"
}

The only scope I’ve added is the non-sensitive “See your primary Google Account email address”. I have set no additional permissions on the Auth0 dashboard, and set all applications to use the connection as well. I can log in to my app just fine with the Auth0 development keys.

Also, I cannot publish my app from Google for some reason, even though I don’t have any sensitive scope. Would appreciate any help. Thanks!

Hi @importhuman,

The “Application type” field should be the first field you select when you start creating a new OAuth client ID:

The next page should look like this:

When you click “CREATE” you should see a modal with the client ID and secret.

The Google social connections should look like this:

Was this selected from the list of scopes in the social connection configs? I don’t see one with that exact wording.

Thanks for the response!

I did see it in the credentials portion where I chose ‘web application’, I meant the one where I’m supposed to select ‘Public’ in the guide portion “While setting up your OAuth consent screen”.

No, this was chosen in the OAuth consent screen section of Google cloud.

Apologies, I must have accidentally marked it as the answer. I’m still facing this issue.