Invalid scopes for Google OAuth v2

As I was enabling google social connection and configuring my Google app, I ran into an unauthorized issue with the oauthError being invalid_request. After further inspecting the request, I noticed the scopes included “email” and “profile”.

Normally, I would think to just go into the Google OAuth consent screen and add the two; however, that doesn’t appear to be possible anymore. Even the manually add scopes section does not let you add these.

Any assistance would be greatly appreciated.

Hey there @ebuckleyk welcome to the community!

The scopes listed in the screenshot look OK to me - These are just the default scopes included without making any additional changes on the Auth0/Google side of things.

Can you confirm that the client id and secret you have added to the connection in Auth0 are correct? I would just delete and re-add those values to be sure.

Let us know if you’re still running into this after re-adding the credentials!

Hey I really appreciate the response! A delete and re-add indeed worked. Thank you!

1 Like

Awesome! Thanks for the update :smiley:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.