Service Not Enabled Within Domain Error When Using an Audience Parameter

Last Updated: Jul 28, 2025

Overview

This article explains the cause of the following error, which occurs when making an API call that specifies an incorrect audience parameter:

Service not enabled within domain

Applies To

  • API Calls
  • Audience Parameter

Cause

This error is caused by setting the audience parameter to a custom domain instead of the required canonical tenant domain. The Management API (Application Programming Interface) requires the canonical domain to be specified as the audience.

Solution

To resolve this error, configure the audience parameter to use the canonical tenant domain. When specifying the audience parameter, it is required to use the tenant’s canonical domain.

Set the audience parameter to the canonical tenant domain URL. For example:

audience: https://<Tenant-Canonical-Domain>

NOTE: When specifying an audience for API calls, the canonical tenant domain must be used. Continue to use the tenant’s custom domain name for other purposes, but remember to include the tenant’s canonical domain when specifying the audience parameter for API calls.