Save Button Does Not Work on the Universal Login Page

Problem statement

Regardless of what is changed on the Universal Login page, the Save Settings button does not seem to work. When attempting to swap to the ‘New Universal Login Experience’ and clicking the ‘Save Changes’ button, nothing happens.

Symptoms

When attempting to swap to the ‘New Unviersal Login Experience’ and clicking the ‘Save Changes’ button, nothing happens.

Steps to reproduce

  1. Ensure your tenant is configured to use the ‘Classic Universal Login Experience’
  2. Update your branding settings to the following:

https://auth0.com/docs/api/management/v2/branding/patch-branding

{
  "colors": {
    "page_background": "#F2F2F2",
    "primary": "#FF825A"
  },
  "font": {
    "url": "https://fonts.googleapis.com/css?family=Roboto+Mono|Roboto+Slab|Roboto:300,400,500,700""
  }
}
  1. Navigate to ‘https://manage.auth0.com/#/login_settings’ and attempt to change to using the ‘New Universal Login Experience’
  2. Click ‘Save Changes’

Cause

The issue is due to the ‘font.url’ parameter in the ‘Branding’ settings containing the “|” pipe character.

E.g. caused by:

"font": {
    "url": "https://fonts.googleapis.com/css?family=Roboto+Mono|Roboto+Slab|Roboto:300,400,500,700""
  }

Solution

Remove this “|” pipe character to resolve the issue and enable the save changes button.