Auth0 Home Blog Docs

Rules fail if name contains @ symbol

bug
rules

#1

Hi,

While working on a new rule, I starting getting this error when trying it out:
Output
ERROR: Unknown error. Possible reason: you are not calling callback(null, user, context)

Turns out this happened after I updated to name of the rule so it contained the @-symbol; removing it resolved the issue.

Doesn’t seem to be documented, and should probably by rejected to avoid confusion.

-Tolli


#3

:wave: @Tolli I just tried this on my rules and got the same result. This behavior actually happens with any special character. Only alphanumeric characters, spaces, and ‘-’ are accepted (and cannot start or end with a space or ‘-’). I was able to find this on the Rules page under Create Rules with the Management API, which as we can see is only listed under the management API and I’m not sure I would have known this when creating it the dashboard. Thank you pointing this out! I will pass this along, it’ll be good to avoid confusion in the future for others!