Auth0 Home Blog Docs

Cannot delete Rules-config with @

api

#1

Hello,

With the Management dashboard Or the Management API V2, rule-config with ‘@’ in the key name can be created.

However:

  • it cannot be deleted : Path validation error: 'String does not match pattern ^[A-Za-z0-9_-]* …
  • it makes the rule system fail (tryout “ERROR: cipher_text.split is not a function”).

I tried removing by API too, same error.


#2

:wave: @MathieuFZ You should not have been able to create a Rule with an invalid name (namely with an “@” symbol). I apologize for the inconvenience this may have caused. You are correct in that the Rule name cannot contain a “@” symbol. It can only contain alphanumeric characters, spaces and ‘-’ (but cannot start nor end with a ‘-’ or spaces). Could you please DM me your tenant name so that we can investigate further and get that Rule removed?


#3

It’s good to have news :slight_smile: My tenant is “firenz” in EU.

I hope the creation miss-validation will be fixed to prevent this (FYI, the rules config was pre-filled with my chrome auto-login plugin (Bitwarden)).

Regards,
Mathieu