Redirect / result_url in change password ticket not working


I’m struggling with the user redirect after a password reset on the hosted page.
It looks as if result_url would be completely ignored.

Here’s what I do:
I create a password reset ticket (handing over user_id and result_url).
All works fine, page opens, password is changed, success message shown.
Result_url is 1:1 as in the allowed callback urls of both: Enduser app and M2M app.

It always just stays on the the changed password success page.

Any hint?

Warm regards,

Hi @sgloeckner,

Welcome to the Auth0 Community!

I just tried to replicate and everything is working as expected. I redirect after the successful pw change.

Here are a few things you can try:

  • DM me your result_url you are trying to use, I want to take a look and see if there is something going on there.

  • Try using a result_url that is a common website, like for instance. No need to register this URL in the dashboard, it should work regardless.

  • If a common website is not working, try opening the pw change link in a different browser, and try in incognito/private browsing mode.

Let me know if any of this works/doesn’t work.


Can confirm this we’re having exactly the same issue.

I can see that the redirect_url value is indeed being set through looking at the logs:

I tried with a common website, and i tried in separate browsers too
Did you make any progress on this?


Ah it appears redirect isn’t currently working if you use the ‘New’ Universal Login experience. I switched back to the ‘Classic’ and redirect worked a charm :+1:

Hope this helps all, and would love to know when it’ll be supported on the New experience

Have a great weekend one and all,

1 Like

Hi @nick10,

Thanks for joining us here in the Community.

I am going to try and reproduce the issue then I will report it to the relevant team.


@sgloeckner @nick10,

I was able to reproduce the problem and it is related the new universal login experience. It is solved by switching to the classic UL experience.

Thanks for figuring it out @nick10!

I am going to report the bug.


Hi @sgloeckner @nick10

The New Universal Login Experience handles it in a different way (it’s explained here New Universal Login Experience).

You can set the Application Login URI (Configure Default Login Routes), and Auth0 will redirect to it in several scenarios that are described in that page.

If that does work for your use case, please let me know.


1 Like

Thank you for clarifying that @andres.aguiar!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

I wrote an FAQ that should help others that are running into this issue:

1 Like