Received an error while calling API for generating token "SSL certificate problem: certificate has expired"

I received an error “SSL certificate problem: certificate has expired” while accessing API for generating token by giving authorization code. Any help? Thanks!


I saw a ton of this today as well. Getting new access tokens was working, but subsequently token validation calls got the same error.


We have been seeing the same problem as well.

1 Like

This is because Auth0’s ssl CA updated to another type today, your (and my) server’s runtime ssl tool does not support it yet. I just solved this issue by upgrade the version(from NodeJS 8 to NodeJS 12). Hope this can help you.
Reference: Expo CLI - Error: certificate has expired - Expo Development Tools - Forums

We had to manually install the updated Root Cert on some of our older estate kit.

Hi! I solved the problem in my server updating OpenSSL:

yum update openssl

You may require to restart server application.

Did Auth0 revert the cert? I was looking at their cert in the morning and now. It seems to have changed

Hi folks, please take a look at this thread:

1 Like

Thanks @dan.woda

Fixed the issue by adding “CURLOPT_SSL_VERIFYPEER => false,” in the curl while calling Auth0 API.


Thanks for sharing that @jttorate !

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.