Query param ?email= missing from post-verification redirect URL


According to this documentation, as far as I understand there should be a email param added to the redirect URL. I’m not getting it on success=true, success=false or any other outcome for that matter.

Am I doing something wrong, or is the documentation not correct?

Using the verification link from the standard email verification (link) template.

// Rune

Hi @ra1,

Welcome to the Auth0 Community!

I have tested the Verification Email myself and can confirm that your observations are expected. Specifically, the email parameter is not added to the redirect URL.

Based on the Customize Email Templates documentation, the only allowed attributes that are allowed to be configured with the Redirect URL are the following:

  • application.name (or its synonym client.name )
  • application.clientID
  • application.callback_domain (or its synonym client.callback_domain )

Hence, the email parameter is not an option that can be included in the Redirect To URL.

Hoped this helps!

Please let me know if you have further questions or concerns.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.