Prompt for Credentials Unavailable after Disabling Passwordless Connection

Last Updated: Aug 12, 2024

Overview

After disabling Passwordless Connection for a given app, the prompts to introduce the username and password are no longer available when trying to log in. The Database connection is enabled for the application.

Applies To

  • Authentication
  • Passwordless Connection Disabled

Cause

Deactivating a Passwordless Connection will not directly enable a Username-Password Login flow.

Solution

To prompt for Username and Password credentials upon login, verify:

  • A Username-Password connection is enabled for the application.
  • If using Classic Universal Login, change the template to be other than Lock (Passwordless).
  • If using New Universal Login, change the Authentication Profile to Identifier + Password.
  • If using Custom hosted login page, check if username/email and password prompts are present in the code.

Related References