Auth0 Home Blog Docs

Phone number is not accepted for MFA

Hello,

When I try to make a request to “/mfa/associate”, with a specific number using the following request, I get a “400 - The phone number is invalid” response.
For other phone numbers the requests works properly, but for this particular number it returns an error even though it’s a regular Canadian mobile phone.
Here is the curl:

curl -v
-X POST
-H “Authorization: Bearer XXX”
-H “Content-Type: application/json”
-d “{“phone_number”:”+1902440XXXX",“oob_channels”:[“sms”],“authenticator_types”:[“oob”],“client_id”:“XXX”}"
https://XXX.auth0.com/mfa/associate

Can someone help?

Thanks in advance,
Edi.

Hello

I’m also having trouble with phone numbers not being accepted. In my case, users get an error message when registering for MFA with US phone numbers. The logs say that the phone numbers are invalid. Works fine for other phone numbers like German, French, Dutch, …

I’m using the hosted guardian multifactor page with mfa-widget version 1.6.

Any ideas? Thanks in advance!

Hey there guys!

Let me research it a bit and get back to you with potential solutions soon!

Hi,

In my case (I asked the original question above), the problem was with Twilio that needs special settings to send SMS to US.
The solution was to use “Copilot” as the SMS source in the SMS MFA settings of Auth0.
Then in Twilio I had to register a US number to be able to receive MFA SMSs.

Good luck,
Edi.

@mobilmacher can you check if the above is also your scenario?

Hey there!

Have you had a chance to see my last message?

Friendly ping, let me know once you have a chance to check my previous messages here :slight_smile: