Permissions naming convention

Hi everyone. I’m new to this community and i would like to know if there’s a naming convention or a pattern for auth0 permissions. I know the main convention is, e.g:
create:user, read:user, etc…
What about create:computerScientist, or create:computer_scientist_dev? This is only an example, but is this correct?
Thank you all in advance.

Hi @miguelcabgil,

Welcome to the Community!

Permissions will often follow the pattern of <verb>:<resource>, however, you do not have to follow this convention. As long as you do not use the reserved names, you can name your API’s permissions as you like.

Common verbs to use are:

  • view
  • create
  • update
  • delete

As far as the casing of the resource (computerScientist vs. computer_scientist_dev), I believe I’ve seen this done using snake case most commonly (e.g. create:computer_scientist_dev), but I don’t know of an official best practice.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.