Password strength bar isn't working as expected

Hi All,

After creating DB conenction, as we can set password strength using a bar to make pass simpler and complex. I have set pass status bar to special characters, but still if i don’t include special characters in my password, It don’t give me an error for that. Please help me on this issue.
Im also attaching screenshot of that.
image

1 Like

Hey there @rashid779939!

Can you tell me more what stack you use (mobile / web), link to any docs of ours that you followed that will let me dig into it deeper? Thank you!

I was trying this using managment API.

Can you tell me which endpoint exactly?

Below mention is exact endpoint:
https://YourDomain/dbconnections/signup

Gotchya! Let me discuss it with our engineering team to see what they can share on that front why the endpoint doesn’t behave as expected.

Thanks for your quick response.

Just tested that endpoint on my own tenant and it properly applied the password policy as expected. @rashid779939 are you sure you clicked on Save Changes at the bottom of password policy tab after changing the password strength policy?

Yup, I just change the policy, saved the setting and test it again. My password policy is set to Special characters (!@#$%^&*). When i try to register new user using signup API i am giving this password aEbEc0dEf and it works. But technically it shouldn’t work.

I reported it to our engineering team. Let me get back to you once I have any info from them!

Hey there @rashid779939!

Sorry for the delay in response but it just seems that the engineering team responsible for that feature just digged it out and they would like me to pass them your tenant name and exact steps that you take so they can reproduce. Can you shoot me a private message with that info? Thank you!

Hey there Rashid! Have you had a chance to check my previous message?

i’ll respond on it tomorrow…

1 Like

Thanks a lot for that!

Ping ping friendly ping :slight_smile:

This topic was automatically closed after 14 days. New replies are no longer allowed.