Passing login_hint to New Universal Login page always prompts password

I’m using auth0/auth0-react 1.6.0 with the loginWithRedirect method and New Universal Login + Identifier first + Biometrics. I’m passing in a login_hint with the user’s email, and when the user lands on the page, it autofills the email and prompts for a password. The problem is, what if this user has some other method of auth configured, such as device biometrics? They won’t ever get to use it since they’re being presented with the password input instead.

I noticed that using login_hint forces the New UL to go to {tenantId}, but I’d really like this to take the user to the /login/identifier route instead so that the user can click continue and get prompted for biometrics instead of a password if they have it set up.

Is there some additional setting or parameter that I should be passing so that I can populate the email using login_hint and NOT be prompted for a password?


Hi @cadin.
There’s no good way to do what you are after as of now, as you said login_hint will take the user to the password authentication page directly when using New Universal Login.

I think this is good feedback for the Product team though. Would you mind filing this feature request at Auth0: Secure access for everyone. But not just anyone.?


Thanks Nicolas. Does this mean you/team aren’t aware of any way to forward a user directly to a biometric or Face ID screen (assuming they have set up/enabled Face ID on their Auth0 account)?

That is correct, there’s no way to send the user to the WebAuthn prompt directly.

1 Like

You can always advocate for that by creating a Feedback card in our Feedback category here:

I’ve created a Feedback post for anyone that finds this thread and has a similar need so they can vote on it. Thanks team!

1 Like

Thanks for update and quick reply, its work for me, really appreciate for help.

1 Like

No worries! We’re here for you!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.