Organization Authorization error - react sdk

  • @auth0/auth0-react": "^1.8.0
  • react “^17.0.2”

Is this a feature request or bug report? If so, please create an issue directly in the corresponding GitHub repo. The Community SDK category is for general discussion and support.

Unsure if this is a bug or I am missing a setting. I am unable to get a this working by passing organizations.

React setup looks like this

ReactDOM.render(
  <React.StrictMode>
    <ThemeProvider theme={theme}>
      <CssBaseline />
      <Auth0Provider domain={providerConfig.domain} clientId={providerConfig.clientId} organization={providerConfig.organization}>
        <BrowserRouter>
          <PageRoutes />
        </BrowserRouter>
      </Auth0Provider>
    </ThemeProvider>
  </React.StrictMode>,
  document.getElementById("root")
);

Calling code :

<Button onClick={loginWithRedirect}>Login</Button>

All seems pretty straight forward based on what I’ve found. However the organization login doesn’t appear to be working as I am landed on this page.

{providerConfig.domain}

Oops!, something went wrong

Organizations are not supported in Classic Universal Login.

TECHNICAL DETAILS

TRACKING ID: da0627a8720584bf083d

SUPPORT

Please contact the systems administrator.

The interesting thing is I do not have Classic Universal Login enabled - it is set to the new Universal Login. I have created a new organization within the same tenant as well to kick the tires on it and it still doesn’t work.

Are there additional settings in getting organizations to login that I am missing?

There are also no logs for this, which is alarming. If I toggle the organization settings to not be “Team members of organizations” then I get a logged error saying organizations are not allowed. Any advice here as this is very confusing would be appreciated.

Hi @colin2,

Welcome to the Auth0 Community!

According to the error message regarding Organizations not being supported in the Classic Universal Login Experience, this is consistent with our Organization Limitations docs.

In this case, could you please check that you have disabled the Customize Login Page in your Universal Login settings?

It is not completely intuitive but when this feature is enabled, it uses the Classic Universal Login Experience under the hood.

Therefore, while enabled, you will see a yellow warning banner indicating these limitations. See below.

Of course, the trade-off is that you won’t be able to use a customized classic universal login page, but you can Customize New Universal Login Pages. There are limitations with requiring custom domains, which is a paid feature.

You can learn more about the difference between the New and Classic Universal Login Experience here

Hoped this helps!

Please let me know if you have any other questions.

Thank you.

That was indeed the problem. Thanks for the quick turnaround. Was a real head scratcher as I thought by having the New Login Experience in the left-most tab would have the final word.

Thanks again!

1 Like

Hi @colin2,

Thank you for your response.

I’m glad to hear that everything is working now.

Please let me know if there’s anything else I can to do help.

Thank you.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.