Okta.yaml is not detected by the okta-sdk-python library

I am using the okta-sdk-python library to handle Okta interations from my python app.
My project structure is the following:

➜  dummy-project ✗ tree -L 1
├── README.md
├── dummy-project
├── docs
├── okta.yaml
└── tests

The code and the library usage is inside dummy-project (path: ~/dummy-project/dummy-project) and okta.yaml is defined at root level ((path: ~/dummy-project/okta.yaml), as indicated in the library documentation.

I have also tried to move okta.yaml to ~/dummy-project/dummy-project/okta.yaml but I get the same error.

'error': {'code': 500, 'message': 'Unexpected internal error:\\n\\nErrors:\\nYour Okta URL is missing. You can copy your domain from the Okta Developer Console. Follow these instructions to find it: https://developer.okta.com/docs/guides/find-your-domain/overview'

My okta.yaml is:

    connectionTimeout: 30 # seconds
    orgUrl: "https://trial-56xxx21.okta.com"
    authorizationMode: "PrivateKey"
    clientId: "0oa..."
      - okta.users.read
      - okta.groups.read
    privateKey: |
      -----BEGIN PRIVATE KEY-----
      MIIEuwIBADA ...
      -----END PRIVATE KEY-----
    requestTimeout: 0 # seconds
      maxRetries: 4
      enabled: true
      logLevel: INFO

As a workaround, I have tried to follow the approach of using environment variables, but unfortunately I have found some errors setting environment variables. See pull request to fix the issue fix: ensure requestTimeout and maxRetries are integers by tgarciaalv · Pull Request #394 · okta/okta-sdk-python · GitHub