Callback URL mismatch The provided redirect_uri is not in the list of allowed callback URLs

I’m new to Okta and am exploring its potential use in a Blazor app Im developing. Ive generated a sample app from the okta web site but I cant get it to work

Ive setup this in the appsettings.json file

“Auth0”: {
“Domain”: “the domain supplied”,
“ClientId”: “the customer Id supplied”


I cant see where I’m supposed to setup the Allowed Callback URLs and Allowed Logout URLs in my app. Ive added these in the dashboard (from my dev machine), I’m assuming they need to be in the app as well ? If so, where ? In the appsetting.json file ? If this is the case, what’s the section name, syntax, etc ?
The error message seems to suggest I need to specify these in my application, If they are specified in the dashboard shouldn’t this work ?

CallBack: https://localhost:44343
Logout: https://localhost:44343

**these are the actual URLs from the demo app on my development machine

when I run the demo app I get this error message when I try to log in

“Oops!, something went wrong
Callback URL mismatch.
The provided redirect_uri is not in the list of allowed callback URLs.
Please go to the Application Settings page and make sure you are sending a valid callback url from your application.”

Im stumped, just cant get this to work, can anyone help ?

Hi @mwwheeler,

The error you encountered states that you have used an incorrect redirect_uri value, which does not match any of the callback URLs you have defined.

I have checked your tenant logs and see that this is true. You passed in https://localhost:7113/callback in your request.

To remedy this, you can include that URL as part of your list of allowed callback URLs or go to your application code and ensure that the redirect_uri references the correct URL.

Let me know how this goes for you.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.