Okta auth0 SSO not working

I am trying to setup SSO connection to Okta from auth0. But my login page - lock.js does not switch to SSO mode - not hiding password field. I have created an application: https://dev-36504359-admin.okta.com/admin/app/oidc_client/instance/0oa7xexluruJq3ifs5d7/*tab-general

and I have configured it in auth0: https://manage.auth0.com/dashboard/au/flowingly-staging/connections/enterprise/okta/con_MsuoBHYdYJWlnhlg/applications to use Okta Workforce connection

My best guess would be that Okta SSO is a paid feature

Hi @andrei4

I tried this out on one of my free tenants and it looks like the Home Realm Discovery aspect should still work, providing the Identity Provider Domains are listed on the connection and an application is mapped on the connection https://auth0.com/docs/libraries/lock/selecting-from-multiple-connection-options#using-email-domains-with-enterprise-connections

There is also a tenant flag that should be enabled in Tenant Settings > Advanced tab

Are you still having this issue?

Warm regards.

1 Like