OIDC Connection and Username/password is only showing username and password fields on login

Hi,

I’m new to Auth0 but am trying to make a quick PoC for a prospective client. The aim is to show them how we can connect an Auth0 app to our OIDC IdP, but also allow their users to log in with username and password instead if they wish.

I’ve modified the default app to also include our OIDC provider (which works fine on its own). The issue is, as soon as I enable either username/password or the default demo Google connection, our OIDC provider disappears from the login form.

Am I doing something wrong or is it not possible to have both OIDC and username/password enabled?

Images of what I am seeing can be found here: https://imgur.com/a/LfOI1DD

Thanks,

You’re using the classic universal experience with Lock; for Lock, once you enable a database connection and there’s also enterprise connections enabled or you have multiple enterprise connections enabled the behavior is to rely on letting the user input his email address first and use that to automatically derive which connection to use.

This would be possible by assigning email domains in the enterprise connection settings so that any address within that domain would trigger Lock to use this connection. The side-effect is that unless the enterprise connection is the only connection, Lock won’t show a dedicated button.

If you strictly require a dedicated button for each enterprise connection you can consider using the new universal login experience instead (https://auth0.com/docs/universal-login/new-experience) which at this time should always render a separate button for the OIDC connection.

2 Likes

That did the job, thank you for the quick reply!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.