Not allowed to set certain flags for particular tenant


I’m using auth0-deploy-cli to deploy configurations to multiple tenants. However, for one of the tenants (I am the admin user), it threw me following error:

    error: You are not allowed to set flag 'include_email_in_reset_pwd_redirect' for this tenant.

Same error occurs for include_email_in_verify_email_redirect flag as well.
Here is a snippet of the tenant section of the yaml config:

  default_redirection_uri: @@TENANT_DEFAULT_REDIRECTION_URI@@
    - en
    new_universal_login_experience_enabled: true
    universal_login: true
    disable_clickjack_protection_headers: false
    include_email_in_reset_pwd_redirect: true
    include_email_in_verify_email_redirect: true
  friendly_name: @@FRIENDLY_NAME@@
  picture_url: @@PICTURE_URL@@
  support_email: @@SUPPORT_EMAIL@@
  support_url: ''

Since all other tenants was able to be deployed with same configurations with no errors. I wonder what could be the cause of this error. Is there any prerequisite for those flags?
Also I’m unable to find those configuration on Auth0 dashboard UI. Wonder where I can manually set those flags?

Thank you,

1 Like

Hey there!

Can I ask you to raise it as a GitHub issue here:

so we can work directly on it with the repo maintainers? Make sure to share the link to the issue here with us so we can ping the tool maintainers. Thank you!

This API needs update:tenant_settings permission. You may check if the application for your auth0-deploy-cli has the required permission with the get client grants management API.

If this doesn’t help, you may try updating this flag with the update tenant settings management API.


Thank you for providing that solution Saltuk!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.