Not able to add the URN to Azure AD while adding Azure AD Multi Tenancy as an Enterprise Connection to Auth0


I’m trying to add Azure AD - Multi tenancy as an enterprise connection to Auth0. I have followed the guides by Auth0 and a lot of other community tutorials/guides where they mention adding the URN to Azure AD.

To name a few,

I was able to create a tenant in Azure AD. Add redirect URI, create client secret and add the required information to the Auth0 console. The auth request gets approved. But the error is thrown after the auth saying “AADSTS700016: Application with identifier ‘’ was not found in the directory ‘’.” So I tried adding the URN to application ID as mentioned in this tutorial (Application With Identifier Not Found: Azure Error - Brian Childress). But the URN is not being accepted when I add it to Application ID in Azure AD. Ideally, it should have. I have already tried Windows live social, Azure AD enterprise in Auth0. This error has been thrown while I was trying to add a SAML connection with Azure AD.

It would be nice if somebody could point me in a right direction and let me know what am I missing here.