Newb question -- hello world react app doesn't work

I’m just trying to follow follow the “choose your own stack” tutorial for React and Express, and I can’t get it working correctly.


  1. When I go to my https://localhost:4040 url, it shows a spinner for 60+ seconds before showing me the page. In the console it reads:

Failed to load resource: the server responded with a status of 400 () …

From the network:Headers panel

Request Method:

Status Code:
400 Bad Request

Remote Address:

Referrer Policy:

  1. After it finally loads, I click “Login” and it brings me to the generic signup/login page. I log in and get to the profile page, which looks correct.

  2. When I click on “Protected” or “Admin” in the nav bar, the message shows:
    “message”: “Requires authentication”

I assume that I am misconfiguring somehow. Here’s me FE .env file…


The tutorial on the site DOES NOT HAVE AN EXAMPLE ENV FILE. So I have no idea if this is right or if I got it totally wrong. It also does not have a troubleshooting section.

Can anyone help me? Thank you in advance!

Hi @vineel

Welcome to the Auth0 Community!

Thank you for posting your question; I’ve edited your code to remove PII information like a domain name or client.

First, you can safely remove the protocol from the Auth0Domain value "https://"; it’s unnecessary and can cause issues. In terms of other values, check if they are aligned with the Auth0 settings that you can check in the Auth0 Dashboard. You can also check if the express server runs on the correct port. Let me know if this helps you.


Thank you for your response Dawid. I removed the https (I had added it when I was trying to make stuff work) and I double-checked all the fields. No joy. I’ve given up on the React tutorial altogether. I assume I made some fatal mistake somewhere along the line and will have no way of figuring out what went wrong.

So, I created a new account with a new email and a new tenant and was able to get a plain javascript app up and running on that, which seems to behave correctly. I’m going to try to climb the learning curve from that.

Thanks again for the response.